Please download and install Java.

The TeleSteth Client application requires Java 6 update 10 or greater in order to run. To install Java, click Download Java button below. Then, accept the download and run the installer. Once Java is successfully installed, the TeleSteth Client will start.

Note: If the TeleSteth Client application does not launch after the Java installation completes, please restart your browser and launch the TeleSteth Client again.